Ha nem indul a VMware Workstation a frissítés után – Manjaro

Megjelent a kis ablak, hogy elérhető friss VMware Workstation verzió, majd rá is kattintottam, hogy frissüljön. A frissítés le is futott szépen (ha nem menne, akkor itt a végén találsz megoldás), de nem akart elindulni, mivel  ugyanaz a hiba, mint telepítés után: nem indul a gui, hibaüzenet nincs. A múltkori megoldás most nem segített.

Szerencsére logol a /tmp/vmware-<id> fájlba, ebben pedig ez az érdekes rész:

appLoader| W115: Unable to load libfontconfig.so.1 from /usr/lib/vmware/lib/libfontconfig.so.1/libfontconfig.so.1: libexpat.so.0: cannot open shared object file: No such file or directory

És valóban, nálam a /usr/lib/-ben nincs libexpat.so.0 csak libexpat.so.1, így hát egy könnyed mozdulattal létrehoztam egy sysmlinket a libexpat.so.1-re:

cd /usr/lib/ && ln -s libexpat.so.1 libexpat.so.0

…és azóta is boldogan fut a friss VMware Workstation 12.5.6 build-5528349 a gépemen, legalábbis a következő frissítésig.

TeamViewer 12 on Manjaro

AUR-ban fent van a teamviewer néven a csomag, ami a 12-es verzió, így onnan fel lehet tenni, de indításkor ezt mondja:

teamviewer –daemon start parancs kiadása után el is indul, de ha azt szeretnéd, hogy ne kelljen minden újraindítás után kiadni, ha használni szeretnéd a programot, akkor még a következő parancsot add ki:

sudo teamviewer --daemon enable

 

Frissült a Java a gépeden a 8u131-es verzióra, és azóta nem indul el egy alkalmazás?

Akkor ez azért (is) lehet, mert a 8u131-es verzióban bekerült a letiltott aláíró algoritmusok közé az MD5. Szóval, ha olyan jar fájl akar betöltődni, ami MD5-el van aláírva, akkor az már nem fog elindulni, a Java console-ban egy ilyesmi Warning jelenik meg:

security: WARNING: The following resource is signed with a weak signature algorithm MD5withRSA and is treated as unsigned: ****.jar This algorithm is now disabled by the security property:
jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024

Nincs más hátra, mint megkeresni a java.security fájlt, ami a jre telepítési könyvtárán belül a lib/security/ könyvtárban van, megkeresni a jdk.jar.disabledAlgorithms sort, és törölni az MD5-öt a felsorolásból, ez maradjon:
jdk.jar.disabledAlgorithms=MD2, RSA keySize < 1024

Persze nem a legjobb megoldás, a legjobb az lenne, ha újabb, tisztább, szárazabb jar fájlt kapnánk a csövön, de valljuk be, azért egy nagyobb környezetben simán belefut az ember olyan Java-s bizbaszba, amit már ezer éve nem fejlesztenek, de még mindig használatban van…

Dell Latitude E5470 BIOS frissítés Windows nélkül

Nem örültem, amikor megláttam a legfrissebb BIOS .exe kiterjesztését a Dell támogatási oldalán, aztán mégsem kellett csalódnom a Dell-ben, mert van lehetőség Windows nélkül is frissíteni a BIOS-t, csak egy FAT-ra formázott pendrive kell hozzá:

  1. A friss .exe Service tag alapján letölt a http://www.dell.com/support/home oldalról
  2. Pendrive-ra felmásol
  3. Boot-nál belépés a Boot menübe (F12), majd BIOS Flash Update
  4. exe kiválaszt és megy is az update

Több infó: http://www.dell.com/support/article/us/en/4/SLN171755/updating-the-dell-bios-in-linux-and-ubuntu-environments?lang=EN

vdi konvertálás vmdk-ra

Egy Virtualbox-os gépet kellett áttennem VMware Workstation alá, viszont az volt a gond, hogy a Virtualbox-os gép .vdi-ben volt, amit a VMWare nem szeret. Szerencsére a Virtualbox meg tudja csinálni a konvertálást:

VBoxManage clonehd virtualboxcucc.vdi vmwarecucc.vmdk --format vmdk

Vagy megy az GUI-n is: File->Virtual Media Manager..-> jobb gomb a vdi-n-> Copy utána pedig egyértelmű.

Redmine 3.3 + Nginx + MariaDB telepítése Ubuntu 16.04-re

A tovább mögött egy nem túl részletes, de talán annál hasznosabb leírást olvashattok a Redmine 3.3 telepítéséről Ubuntu 16.04-re nginx webszerverrel és MariaBD adatbázissal. Aki telepített már valaha Redmine-t, az tudja, hogy elég magas a random faktor a dolog sikerességében, így amikor elkezded sosem lehetsz biztos benne, hogy sikerülni is fog, ezért nem tudom garantálni, hogy ez alapján sikerülni fog neked is, de hátha, ha mégsem, akkor meg sörért telepíthetek Redmine-t :)

Tovább Redmine 3.3 + Nginx + MariaDB telepítése Ubuntu 16.04-re